EIGRP_Show_IPROUTE_RouterC

Cisco ICND2 – Configure, verify and troubleshoot EIGRP

Next routing protocol up is configure, verify and troubleshoot EIGRP.

Using the same layout from OSPF, we will re-configure for EIGRP.

OSPF_Diagram

First turn off ospf on the routers

configure terminal
no router ospf 1

Configuring EIGRP is similar to that of OSPF.

RouterA

configure terminal
router eigrp 1
network 10.0.3.68 0.0.0.3
network 10.0.3.72 0.0.0.3
network 10.0.3.32 0.0.0.31
network 10.0.0.0 0.0.0.255
no auto-summary

RouterB

configure terminal
router eigrp 1
network 10.0.1.0 0.0.0.255
network 10.0.3.64 0.0.0.3
network 10.0.3.0 0.0.0.31
network 10.0.3.68 0.0.0.3
no auto-summary

RouterC

configure terminal
router eigrp 1
network 10.0.2.0 0.0.0.255
network 10.0.3.64 0.0.0.3
network 10.0.3.72 0.0.0.3
no auto-summary

Verify EIGRP

Router A routing table:

EIGRP_Show_IPROUTE_RouterA

Router B routing table:

EIGRP_Show_IPROUTE_RouterB

Router C routing table:

EIGRP_Show_IPROUTE_RouterC

  • show ip route eigrp
  • show ip eigrp neighbors
  • show ip eigrp topology
  • show ip protocols
  • ping remote computers/WAN links

Troubleshoot EIGRP

  • Autonomous number must match
  • Like OSPF, the EIGRP timers must match
  • If routing tables not advertising correct routes, auto summary may be enabled, I like to turn auto  summary off
  • debug eigrp packet
  • debug ip eigrp neighbor
OSPF_Diagram

Cisco ICND2 – Configure, verify and troubleshoot OSPF

In this topic we will configure OSPF, verify and troubleshoot using show commands and what kinds of problems we can expect and how we can resolve these.

I have made some changes to our switch diagrams and added a couple of routers and re-jigged things around:

OSPF_Diagram

To enable OSPF we first need to enable the routing protocol:

configure terminal
router ospf 1

The value 1 is the instance number, this can be anything between 1 and 65535. Next we need to let the routing process know which networks we want to advertise, for example:

network 192.168.0.1 0.0.0.255 area 0

OSPF uses inverse (wildcard) subnet mask. The 0’s mean we want this part of the IP to exactly match (192.168.0.) and the last octet 255 means it can be any value. Area 0 is the backbone area for OSPF. I have kept this simple.

We can stop OSPF hellos being sent out of an interface using the passive-interface command. This  can be useful on FastEthernet links that are connected to a switch network that do not need to receive routing updates. Sending routing updates to unnecessarily links can waste bandwidth and CPU resources also enhances security.

configure terminal
router ospf 1
passive-interface FastEthernet0/0

Below are the outputs of the commands for each device needed to make the diagram above fully functional:

RouterA:

configure terminal
interface FastEthernet 0/0
no shutdown
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.0.0.1 255.255.255.0
interface FastEthernet1/0
no shutdown
interface FastEthernet1/0.50
encapsulation dot1Q 50
ip address 10.0.3.33 255.255.255.224
interface Serial0/0
ip address 10.0.3.73 255.255.255.252
interface Serial0/1
ip address 10.0.3.70 255.255.255.252
router ospf 1
network 10.0.3.68 0.0.0.3 area 0
network 10.0.3.0 0.0.0.127 area 0
network 10.0.3.72 0.0.0.3 area 0
network 10.0.0.0 0.0.0.255 area 0
passive-interface FastEthernet 0/0
passive-interface FastEthernet 1/0

RouterB:

configure terminal
interface FastEthernet0/0
no shutdown
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.0.1.1 255.255.255.0
interface FastEthernet1/0
no shutdown
interface FastEthernet1/0.40
encapsulation dot1Q 40
ip address 10.0.3.1 255.255.255.224
interface Serial0/0
ip address 10.0.3.66 255.255.255.252
interface Serial0/1
ip address 10.0.3.69 255.255.255.252
clock rate 64000
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
network 10.0.3.64 0.0.0.3 area 0
network 10.0.3.0 0.0.0.127 area 0
network 10.0.3.68 0.0.0.3 area 0
passive-interface FastEthernet 0/0
passive-interface FastEthernet 1/0

RouterC:

configure terminal
interface FastEthernet0/0
no shutdown
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.0.2.1 255.255.255.0
interface Serial0/0
ip address 10.0.3.74 255.255.255.252
clock rate 64000
interface Serial0/1
ip address 10.0.3.65 255.255.255.252
clock rate 64000
router ospf 1
network 10.0.2.0 0.0.0.255 area 0
network 10.0.3.72 0.0.0.3 area 0
network 10.0.3.64 0.0.0.3 area 0
passive-interface FastEthernet0/0

SwitchA:

configure terminal
spanning-tree mode rapid-pvst
interface FastEthernet0/1
switchport mode trunk
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
interface range FastEthernet0/3-24
switchport mode access
spanning-tree portfast

SwitchB:

configure terminal
spanning-tree mode rapid-pvst
interface FastEthernet0/1
switchport mode trunk
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
spanning-tree portfast
interface range FastEthernet0/3-24
switchport mode access
spanning-tree portfast

SwitchC:

configure terminal
spanning-tree mode rapid-pvst
interface FastEthernet0/1
switchport mode trunk
interface FastEthernet0/2
switchport access vlan 30
switchport mode access
spanning-tree portfast
interface range FastEthernet0/3-24
switchport mode access
spanning-tree portfast

SwitchD:

configure terminal
spanning-tree mode rapid-pvst
interface FastEthernet0/1
switchport mode trunk
interface FastEthernet0/2
switchport access vlan 50
switchport mode access
spanning-tree portfast
interface Range FastEthernet0/3-24
switchport mode access
spanning-tree portfast

SwitchE:

configure terminal
spanning-tree mode rapid-pvst
interface FastEthernet0/1
switchport mode trunk
interface FastEthernet0/2
switchport access vlan 40
switchport mode access
spanning-tree portfast
interface Range FastEthernet0/3-24
switchport mode access
spanning-tree portfast

OSPF by default uses the highest IP address for its routing process ID. The routing process ID is used to elect DR and BDR as well as advertise routes. For this reason, it may be a good idea to create a loopback interface to override this to ensure that becomes RID, Cisco even suggests using loopbacks.

Configuring a loopback is easy, lets do this on RouterC:

configre terminal
interface loopback 1
ip address 192.168.0.1 255.255.255.0

This doesn’t automatically make the RID become 192.168.0.1 we must either reload the router – Which could be inconvenient in a live environment or we can using the command router-id 192.168.0.1 to force the change.

configure terminal
router ospf 1
router-id 192.168.0.1

We can advertise default routes via the default-information originate command under the OSPF configuration. We can also use default-information originate always (not supported in Packet Tracer) – This advertises a default route even if one doesn’t exist, it will generate one and advertise this. To create a default route:

configure terminal
ip route 0.0.0.0 0.0.0.0 s0/1

Verify OSPF

Lets first begin by checking the RID of RouterC – We can verify this by using the show ip ospf command on RouterC:

Show_IP_OSPF_RouterC

We can check OSPF routes via the show ip route command:
OSPF_Show_IP_Route_RouterC

We can verify WAN connectivity by pinging each PC from each other. I’m going to demonstrate PC3 pinging PC1:

OSPF_Ping_PC1_From_PC2

show ip osfneighbor will show information about all neighbors:

OSPF_Show_IP_neighbor_RouterB

show ip ospf interface s0/0 will display information about the interface state whether it is up and OSPF information such as timers, what area the interface is in and network type.
OSPF_Show_IP_int_RouterA

Troubleshoot OSPF

  • Ensure you’re using a wildcard mask and not a subnet mask when configuring OSPF
  • Check IP addressing and subnet masks are correctly configured on WAN links
  • Serial interfaces with a DCE cable attached must be configured with the clock rate command
  • Routers running OSPF must have the same hello and dead timers to form a adjacency
  • If using OSPF authentication must be match on other routers
  • You may have accidentally configured passive-interface on a Serial interface running OSPF – this will stop advertisements
  • debug ip ospf adj – shows elections for DR and BDR
  • debug ip ospf packet – shows ospf hello packets being received by the router
  • debug ip ospf hello – shows more in depth information relating to hello packets including being sent and received by the router

You can download the Packet Tracer file here:
Download Packet Tracer OSPF configuration

Cisco ICND2 – Compare and contrast methods of routing and routing protocols

Routing protocols are used to dynamically learn advertised routes from nearby routers. Imagine having to enter every possible route onto each router – nightmare.

Key information about some routing protocols covered by the ICND2:

EIGRP (Enhanced Interior Gateway Routing Protocol)

  • Distance-vector protocol
  • Classless
  • Autonomous system – must be in the same autonomous system
  • Cisco proprietary
  • Administrative distance 90
  • Shows as ‘D’ in the routing table
  • Only routing protocol to use backup routes
  • Supports IPv6 routed protocols
  • Feasible successor – backup route – stored in topology table
  • Successor – best route to a network – store in routing table
  • Uses bandwidth and delay to determine best path
  • Uses subnet mask
  • multicast 224.0.0.10
  • Dual algorithm
  • Maintains three tables neighbor, topology and routing table.

OSPF (Open Shortest Path First)

  • Link-state routing protocol
  • Open standard protocol from IETF this makes OSPF more popular
  • Administrative distance 110
  • Shows as ‘O’ in the routing table
  • Unlimited hop count
  • Path metric – bandwidth
  • Supports IPv6 routed protocols
  • Converges quickly, not as quick as EIGRP
  • Router ID is determined by highest IP first either by loopback or active interfaces
  • multicast 224.0.0.5
  • Uses wild card (inverse mask)
  • SPF algorithm
  • All areas must be connected to area 0
  • Hello packets sent on the configured interface once every 10 seconds on broadcast and 30 seconds on NBMA (non-broadcast multi-access) networks such as frame-relay

Cisco ICND2 – Identify and correct common problems associated with IP addressing and host configurations

Troubleshooting local network issues:

First, from the computer ping the local loopback 127.0.0.1 this will ensure the NIC is functioning correctly.

Second, ping the Default Gateway for example 192.168.0.1 if this fails try and ping another PC on the same network.

To find the default gateway that is set (normally via DHCP) on a Windows machine Start > Run > Type cmd and enter – in the black box type “ipconfig /all” followed by enter. This will display information relating to IP, DNS, Default Gateway and Subnet mask.

If both pinging the default gateway and another PC fail and you have a working PC – verify the PC that isn’t working is in the same subnet by running an ipconfig /all and compare the IP, subnet mask and default gateway.

Tracert can be handy to see where the packets drop off and may help identify where the fault lies.

Try and ping (if have access) from router to router to test connectivity.

Most issues are configured with an incorrect IP, Subnet mask or default gateway. A good example of this is one I encountered recently. There was a PC that could talk to a printer offsite but not on site on inspecting further the printer had the wrong subnet mask, meaning when the PC was on site, the printer was in a totally different subnet to that of the PC – a quick amendment of the mask and boom it worked. Easily missed.

Always consult with network documentation to ensure IP addressing is correct with VLSM networks. As as last resort use a Subnet calculator such as Bitcricket beware you’re not allowed a calculator on the exam.

Summary:

  1. Ping 127.0.0.1
  2. Ping another PC on same network to verify connectivity
  3. Ping Default Gateway (cmd> ipconfig all)
  4. Ping DNS servers
  5. Ping router to router
  6. Tracert to see where packets are dropped
  7. Check cables
  8. Consult with network documentation, if unsure use a subnet calculator

Cisco ICND2 – Describe IPv6 addresses

Some differences between IPv4 and IPv6:

  • Address size increased from 32bit – 128bit
  • 8 groups 4 hex characters each
  • Periods (.) replaced by colons (:)
  • Loopback 0:0:0:0:0:0:0:1 or ::1

Here is an example of a IPv6 address:

2013:0022:0000:0000:0FA1:76BB:EB67:00BB

We can make the IPv6 a little easier to read by removing consecutive zeros and replacing them with :: we can only do this once.

2013:0022::0FA1:76BB:EB67:00BB

We can take this further and drop the leading zeros, this can be done multiple of times.

2013:22::FA1:76BB:EB67:BB

IPv6-01 Making sense out of an IPv6 Address by Keith Barker
IPv6-02 Lov’n the Link Local Address by Keith Barker

Cisco ICND2 – Describe the technological requirements for running IPv6 (including: protocols, dual stack, tunneling, etc)

IPv6 is the new IP addressing scheme that will be replacing IPv4. Why? We are running out of IPv4 addresses. As technology is growing (smartphones, tablets, fridges with internet) with more and more devices being attached to the Internet via 3G/4G/Broadband etc and consuming IPv4 addresses.

Requirements for running IPv6

  • Routers and Switches must support IPv6
  • Operating system and NICs must support IPv6 (recent one do, legacy ones maybe not)
  • Its possible to run IPv4 and IPv6 using Dual Stacking
  • Tunneling for IPv6 to communicate over an IPv6 network to reach another IPv6 network

RIPng

  • Same features as the traditional RIP
  • Support for IPv6
  • Does not support authentication
  • UDP port now 521 instead of port 520
  • Multicast FF02::9
  • Run an instance of RIPng per interface
  • network command has been replaced by ipv6 rip 1 enable

EIGRPv6

  • Same features as the traditional EIGRP
  • Support for IPv6
  • Multicast FF02::A
  • network command replaced by ipv6 router eigrp 5
  • Must no shutdown the routing process

OSPFv6

  • Same features as the traditional OSPF
  • Multicast FF02::5 for OSPF routers / FF02::6 for OSPF-designated routers

Dual stack

  • Allows IPv6 and IPv4 to run alongside each other

Tunneling

  • Encapsulates IPv6 packets within IPv4
  • Allows an IPv6 to communicate over an IPv4 network to reach another IPv6 network

Cisco ICND2 – Determine the appropriate classless addressing scheme using VLSM and summarization to satisfy addressing requirements in a LAN/WAN environment

Route Summarization

Route summarization is summarising a range of subnets as one. Route summarization is commonly used in routing protocols to reduce how many entries are in a routing table and to reduce packet size. Having many routes can slow the routing process down so it is best practise to summarise where possible.

Example one

We want to summarise the following routes as one:

192.168.2.20
192.168.2.21
192.168.2.22
192.168.2.23
192.168.2.24

We’ll first convert each of these IPs to binary and find the common bits.

11000000.10101000.00000010.00010100 192.168.2.20
11000000.10101000.00000010.00010101 192.168.2.21
11000000.10101000.00000010.00010110 192.168.2.22
11000000.10101000.00000010.00010111 192.168.2.23
11000000.10101000.00000010.00011000 192.168.2.24

I have highlighted the common bits above. If we look at the last octet we’ll notice 0001 are common this equates to 4 bits if we convert these 4 bits to a subnet mask we’ll end up with 240 (128, 192, 224, 240). The summarization route will be 192.168.2.20 /28

Example two

We want to summarise the following three IPs:

172.16.0.58
172.20.0.59
172.30.0.60

Lets convert these to binary:

10101100.00010000.00000000.00111010 172.16.0.58
10101100.00010100.00000000.00111011 172.20.0.59
10101100.00011110.00000000.00111100 172.30.0.60

Highlighted are the common bits, the second octet we have four common bits 0001 – if we convert these 4 bits to a subnet mask we’ll end up with 240.

The route summarization is 172.16.0.0 255.240.0.0 or /12

WAN Links

When configuring WAN links between routers it would be a waste to assign a /24 bit subnet mask. Lets think about this, how many IPs do we need between two routers? two. One for the each end of the WAN link.

If we only need two IP addresses, which subnet mask would be the most efficient one to use? Lets have a look at the following subnet masks and how many hosts we can get from each:

128 – 126 hosts
192 – 62 hosts
224 – 30 hosts
240 – 14 hosts
248 – 6 hosts
252 – 2 hosts

We can see 252 will give us 2 hosts. The most efficient mask to use on a WAN link would be 255.255.255.252 or /30.