ESXi 5.1 patch may cause LANDesk cismbios.sys to BSOD

So we had a problem today where we patched a couple of our ESXi and it would seem one of these patches doesn’t play well with LANDesk (cismbios.sys) and blue screens causing a restart loop. I’m not exactly sure what update causes this, but we fully patched up until the 18/03/2015.

cismbios

Someone else on the VM forums seems to be having the same issue: https://communities.vmware.com/message/2484230#2484230

We contacted both VMware and LANDesk, luckily LANDesk are aware of the issue and are in the process of testing a fix for this. The defect # is TFS 303111.

We have found this only occurs when powering a VM on a host that is patched, powering on a non patched host and then migrating across to a patched host doesn’t cause the restart loop. This only seems to happen on Windows 7 VMs.

A work around we found was to make a registry change via group policy that disables cismbios.sys, now in our testing this hasn’t seemed to cause any issues – please test this in your environment before pushing this key out.

We found changing the following key stops the blue screen:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\CISMBIOS]
Start=dword:00000004

If you have patched all your hosts then this may not get a chance to apply via group policy, you may need to make changes in safe mode – can be a pain if you have a lot of VMs.

So far this has stopped the restart loop, once LANDesk issue a fix we will revert this key back via group policy.

  • Arindam Paul

    Thank you so-much Chris, we faced the similar issue after up-gradating hardware version of a VM.
    Raised a support case with vmware but no luck.
    Suddenly found your post and modify the registry as mentioned above, after that issue got resolved.

    Again thanks for your great post. 🙂

    • You’re welcome Arindam! Glad it helped you in your situation! ☺